<!doctype html>

<!--[if lt IE 7]><html lang="en-US" class="no-js lt-ie9 lt-ie8 lt-ie7"><![endif]-->
<!--[if (IE 7)&!(IEMobile)]><html lang="en-US" class="no-js lt-ie9 lt-ie8"><![endif]-->
<!--[if (IE 8)&!(IEMobile)]><html lang="en-US" class="no-js lt-ie9"><![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" class="no-js"><!--<![endif]-->

	<head>
		<meta charset="utf-8">
		<meta http-equiv="X-UA-Compatible" content="IE=edge">

		<title>Gigaom |   The Future of Business is a Digital Spokesperson &mdash; Let’s Build a Preview Using Microsoft’s Bot Framework</title>

		<meta name="HandheldFriendly" content="True">
		<meta name="MobileOptimized" content="320">
		<meta name="viewport" content="width=device-width, initial-scale=1"/>

		<link rel="apple-touch-icon" href="https://gigaom.com/wp-content/themes/go-ossein/library/images/apple-touch-icon.png">
		<link rel="icon" href="https://gigaom.com/wp-content/themes/go-ossein/favicon.png">
		<!--[if IE]>
			<link rel="shortcut icon" href="https://gigaom.com/wp-content/themes/go-ossein/favicon.ico">
		<![endif]-->
		<meta name="msapplication-TileColor" content="#2a2e33">
		<meta name="msapplication-TileImage" content="https://gigaom.com/wp-content/themes/go-ossein/library/images/win8-tile-icon.png">
		<meta name="theme-color" content="#ecebe6">

		<link rel="pingback" href="https://gigaom.com/xmlrpc.php">

		<!-- Facebook Pixel Code -->
		<script>
		!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
		n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
		n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
		t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
		document,'script','https://connect.facebook.net/en_US/fbevents.js');

		fbq('init', '1157339287680303');
		fbq('track', "PageView");</script>
		<noscript><img height="1" width="1" style="display:none"
		src="https://www.facebook.com/tr?id=1157339287680303&ev=PageView&noscript=1"
		/></noscript>
		<!-- End Facebook Pixel Code -->
		<!-- LinkedIn Pixel Code -->
		<script type="text/javascript">
		_linkedin_data_partner_id = "16441";
		</script><script type="text/javascript">
		(function(){var s = document.getElementsByTagName("script")[0];
		var b = document.createElement("script");
		b.type = "text/javascript";b.async = true;
		b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js";
		s.parentNode.insertBefore(b, s);})();
		</script>
		<!-- End LinkedIn Pixel Code -->
				<script>
					(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
					function go_google_analytics_get_cookie( cname ) {
			var name = cname + "=";
			var ca = document.cookie.split( ';' );
			for ( var i = 0; i < ca.length; i++ ) {
				var c = ca[i].trim();
				if ( c.indexOf( name ) == 0 ) {
					return decodeURIComponent( c.substring( name.length, c.length ) );
				}//end if
			}//end for
			return "";
		}//end go_google_analytics_get_cookie

		var gigaom_analytics = go_google_analytics_get_cookie( 'gigaom_analytics' );

		var ga_data = {};
		var ga_user_role = 'anonymous';

		if ( 'undefined' != typeof gigaom_analytics && "" !== gigaom_analytics ) {
			gigaom_analytics = gigaom_analytics.split( '|' );
			ga_data.userId = gigaom_analytics[0].toString();
			ga_user_role = gigaom_analytics[1];
		}//end if

		ga( 'create', 'UA-1136722-40', 'gigaom.com', ga_data );
		ga( 'set', 'dimension4', ga_user_role );
							ga( 'set', 'dimension3', 'christinaberry13' );
										ga( 'set', 'dimension2', 'ai' );
							ga( 'set', 'dimension1', 'gigaom' );
		ga('require', 'displayfeatures');

		
		ga( 'send', 'pageview' );
		</script>
		<link rel='dns-prefetch' href='//assets.juicer.io' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Gigaom &raquo; Feed" href="https://gigaom.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Gigaom &raquo; Comments Feed" href="https://gigaom.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Gigaom &raquo; The Future of Business is a Digital Spokesperson &mdash; Let’s Build a Preview Using Microsoft’s Bot Framework Comments Feed" href="https://gigaom.com/2017/06/06/the-future-of-business-is-a-digital-spokesperson-lets-build-a-preview-using-microsofts-bot-framework/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/gigaom.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.5"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='go-user-profile-enterprise-admin-settings-css'  href='https://gigaom.com/wp-content/plugins/go-enterprises/components/css/go-user-profile-enterprise-admin-settings.css?ver=1' type='text/css' media='screen' />
<link rel='stylesheet' id='colorbox-css'  href='https://gigaom.com/wp-content/plugins/go-ui/components/js/external/colorbox/colorbox.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='go-local-subscriptions-css'  href='https://gigaom.com/wp-content/plugins/go-local-subscriptions/components/css/go-local-subscriptions.css?ver=1445622806' type='text/css' media='all' />
<link rel='stylesheet' id='juicerstyle-css'  href='//assets.juicer.io/embed.css?ver=4.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='go-ads-css'  href='https://gigaom.com/wp-content/plugins/go-ads/components/css/go-ads.css?ver=2' type='text/css' media='all' />
<link rel='stylesheet' id='go-enterprises-css'  href='https://gigaom.com/wp-content/plugins/go-enterprises/components/css/go-enterprises.css?ver=1445622806' type='text/css' media='all' />
<link rel='stylesheet' id='wc_quick_buy__plugin_style-css'  href='https://gigaom.com/wp-admin/admin-ajax.php?action=wc_quick_buy_style&#038;ver=1.2' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-layout-css'  href='//gigaom.com/wp-content/plugins/woocommerce/assets/css/woocommerce-layout.css?ver=2.6.13' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-smallscreen-css'  href='//gigaom.com/wp-content/plugins/woocommerce/assets/css/woocommerce-smallscreen.css?ver=2.6.13' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='woocommerce-general-css'  href='//gigaom.com/wp-content/plugins/woocommerce/assets/css/woocommerce.css?ver=2.6.13' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://gigaom.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.73.2' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://gigaom.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='ye_dynamic-css'  href='https://gigaom.com/wp-content/plugins/youtube-embed/css/main.min.css?ver=4.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://gigaom.com/wp-content/plugins/go-ui/components/css/font-awesome.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://gigaom.com/wp-includes/css/dashicons.min.css?ver=4.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='go-ossein-stylesheet-css'  href='https://gigaom.com/wp-content/themes/go-ossein/library/css/style.css?ver=7' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='go-ossein-ie-only-css'  href='https://gigaom.com/wp-content/themes/go-ossein/library/css/ie.css?ver=4.7.5' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='go-ossein-icons-font-css'  href='https://gigaom.com/wp-content/themes/go-ossein/library/css/font.css?ver=4.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='easy_table_style-css'  href='https://gigaom.com/wp-content/plugins/easy-table/themes/default/style.css?ver=1.6' type='text/css' media='all' />
<script type='text/javascript' src='https://gigaom.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://gigaom.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _zxcvbnSettings = {"src":"https:\/\/gigaom.com\/wp-includes\/js\/zxcvbn.min.js"};
/* ]]> */
</script>
<script type='text/javascript' src='https://gigaom.com/wp-includes/js/zxcvbn-async.min.js?ver=1.0'></script>
<script type='text/javascript' src='//assets.juicer.io/embed-no-jquery.js?ver=4.7.5'></script>
<script type='text/javascript' src='https://gigaom.com/wp-content/plugins/go-datamodule/components/external/highcharts/highcharts.js?ver=4.7.5'></script>
<script type='text/javascript' src='https://gigaom.com/wp-content/plugins/go-datamodule/components/js/go-datamodule-helpers.js?ver=4.7.5'></script>
<script type='text/javascript' src='https://gigaom.com/wp-content/plugins/woocommerce-quick-buy/includes/js/frontend.js?ver=1.2'></script>
<script type='text/javascript' src='https://gigaom.com/wp-content/themes/go-ossein/library/js/libs/modernizr.custom.min.js?ver=2.5.3'></script>
<script type='text/javascript' src='https://gigaom.com/wp-content/themes/go-ossein/library/js/libs/jquery.ba-throttle-debounce.min.js?ver=1.2'></script>
<link rel='https://api.w.org/' href='https://gigaom.com/wp-json/' />
<link rel="canonical" href="https://gigaom.com/2017/06/06/the-future-of-business-is-a-digital-spokesperson-lets-build-a-preview-using-microsofts-bot-framework/" />
<link rel='shortlink' href='https://gigaom.com/?p=953710' />
<link rel="alternate" type="application/json+oembed" href="https://gigaom.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgigaom.com%2F2017%2F06%2F06%2Fthe-future-of-business-is-a-digital-spokesperson-lets-build-a-preview-using-microsofts-bot-framework%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://gigaom.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgigaom.com%2F2017%2F06%2F06%2Fthe-future-of-business-is-a-digital-spokesperson-lets-build-a-preview-using-microsofts-bot-framework%2F&#038;format=xml" />
<meta name="news_keywords" content="ai, gigaomai">
<meta name="keywords" content="ai, gigaomai" />
<meta name="msvalidate.01" content="6AFF4FA8C591A576B80A612AF591A343" /><meta name="google-site-verification" content="0QAgqohqhkW__EGKv9v-VDR1CDFf5J8WJsPPePSTgdU" /><meta name="y_key" content="a09dd3172406080e" /><meta name="google-site-verification" content="qCPIC6UK_23CR6SxLn2bCjE-Ow0OSYoDExoi699IE98" /><meta name='dcterms.publisher' content='Gigaom' /> 
<meta name='dcterms.title' content='The Future of Business is a Digital Spokesperson &mdash; Let’s Build a Preview Using Microsoft’s Bot Framework' /> 
<meta name='dcterms.creator' content='Christina Berry' /> 
<meta name='dcterms.modified' content='2017-06-06' /> 
<meta name='dcterms.created' content='2017-06-06' /> 
<meta name='dcterms.date' content='2017-06-06' /> 
<meta name='dcterms.subject' content='ai; gigaomai' /> 
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","headline":"The Future of Business is a Digital Spokesperson &mdash; Let\u2019s Build a Preview Using Microsoft\u2019s Bot Framework","url":"https:\/\/gigaom.com\/2017\/06\/06\/the-future-of-business-is-a-digital-spokesperson-lets-build-a-preview-using-microsofts-bot-framework\/","thumbnailUrl":"https:\/\/gigaom.com\/wp-content\/uploads\/sites\/1\/2017\/06\/chair-1850612_1920.jpg","dateCreated":"2017-06-06T13:37:52+0000","articleSection":null,"creator":"Christina Berry","keywords":["ai","gigaomai"]}</script><meta name="description" content="Everyone loves a great conversation. And the conversational U.I. is coming on quickly. Chatbots have been all the rage for the past&hellip;" /><meta name="robots" content="NOODP" /><meta name="author" content="Christina Berry" />		<meta name="application-name" content="Gigaom"/>
		<meta name="msapplication-TileColor" content="#ffffff"/>
		<meta name="msapplication-TileImage" content="https://gigaom.com/wp-content/themes/go-ossein/library/images/favicons/mstile-144x144.png"/>
					<script src="https://use.typekit.net/wqs2sjn.js"></script>
			<script>try{Typekit.load({ async: true });}catch(e){}</script>
							<meta property="og:image" content="https://gigaom.com/wp-content/uploads/sites/1/2017/06/chair-1850612_1920-680x453.jpg" />
							<meta name="twitter:card" content="summary_large_image">
			<meta name="twitter:site" content="@gigaom">
			<meta name="twitter:title" content="The Future of Business is a Digital Spokesperson &mdash; Let’s Build a Preview Using Microsoft’s Bot Framework">
							<meta name="twitter:image" content="https://gigaom.com/wp-content/uploads/sites/1/2017/06/chair-1850612_1920-680x453.jpg">
							<meta name="twitter:description" content="Everyone loves a great conversation. And the conversational U.I. is coming on quickly. Chatbots have been all the rage for the past couple of years &amp;mda...">
			<meta name="description" content="Everyone loves a great conversation. And the conversational U.I. is coming on quickly. Chatbots have been all the rage for the past couple of years &amp;mda...">
			<link rel="amphtml" href="https://gigaom.com/2017/06/06/the-future-of-business-is-a-digital-spokesperson-lets-build-a-preview-using-microsofts-bot-framework/amp/" />		<script type="text/javascript">
		window.heap=window.heap||[],heap.load=function(e,t){window.heap.appid=e,window.heap.config=t=t||{};var n=t.forceSSL||"https:"===document.location.protocol,a=document.createElement("script");a.type="text/javascript",a.async=!0,a.src=(n?"https:":"http:")+"//cdn.heapanalytics.com/js/heap-"+e+".js";var o=document.getElementsByTagName("script")[0];o.parentNode.insertBefore(a,o);for(var r=function(e){return function(){heap.push([e].concat(Array.prototype.slice.call(arguments,0)))}},p=["clearEventProperties","identify","setEventProperties","track","unsetEventProperty"],c=0;c<p.length;c++)heap[p[c]]=r(p[c])};
		heap.load("505413567");
		</script>
			</head>

	<body class="post-template-default single single-post postid-953710 single-format-standard singular" itemscope itemtype="http://schema.org/WebPage">

		<div id="container">
						<header class="header" role="banner" itemscope itemtype="http://schema.org/WPHeader">
				<section class="primary cf">
					<div class="wrap">
						<button id="nav-toggle" class="goicon icon-menu"></button>
								<div class="gigaom-logo" itemscope itemtype="http://schema.org/Organization">
			<a href="https://gigaom.com" rel="publisher" title="Gigaom">
				<img src="https://gigaom.com/wp-content/themes/go-ossein/library/images/gigaom-logo.svg" alt="Gigaom logo">
			</a>
		</div>
															<div class="subscribe-form">
								<script type="text/javascript">(function() {
	if (!window.mc4wp) {
		window.mc4wp = {
			listeners: [],
			forms    : {
				on: function (event, callback) {
					window.mc4wp.listeners.push({
						event   : event,
						callback: callback
					});
				}
			}
		}
	}
})();
</script><!-- MailChimp for WordPress v4.0.12 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-950574 mc4wp-ajax" method="post" data-id="950574" data-name="Newsletter sign up (header)" ><div class="mc4wp-form-fields"><input type="email" name="EMAIL" placeholder="Get our newsletter" required />
<button type="submit" class="button"><span class="dashicons dashicons-email-alt"></span></button><div style="display: none;"><input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></div><input type="hidden" name="_mc4wp_timestamp" value="1496807338" /><input type="hidden" name="_mc4wp_form_id" value="950574" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /></div><div class="mc4wp-response"></div></form><!-- / MailChimp for WordPress Plugin -->							</div>
													<ul class="social-subscribe">
							<li class="twitter"><a href="https://twitter.com/Gigaom"><span class="goicon icon-twitter"></span></a></li>
							<li class="facebook"><a href="https://www.facebook.com/Gigaom/"><span class="goicon icon-facebook"></span></a></li>
							<li class="linkedin"><a href="https://www.linkedin.com/company/Gigaom"><span class="goicon icon-linkedin"></span></a></li>
						</ul>
						<div class="user-nav">
							<nav id="user-nav">
								<ul>
									<!-- <li><a href="https://gigaom.com/services/">Services</a></li> -->
									<li><a href="https://gigaom.com/contact/">Contact</a></li>
																				<li><a href="https://gigaom.com/subscription/sign-in/?redirect_to=https%3A%2F%2Fgigaom.com%2F2017%2F06%2F06%2Fthe-future-of-business-is-a-digital-spokesperson-lets-build-a-preview-using-microsofts-bot-framework%2F">Sign in</a></li>
																						<a href="https://gigaom.com/subscriptions/" class="button">Subscribe</a>
																			</ul>
							</nav>
						</div>
					</div>
				</section>

				<section class="secondary cf">
					<div class="wrap">
						<nav id="main-nav" role="navigation" itemscope itemtype="http://schema.org/SiteNavigationElement">
							<ul id="menu-main-menu" class="nav top-nav cf"><li id="menu-item-949624" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-949624"><a href="/topics/">Topics</a></li>
<li id="menu-item-949627" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-949627"><a href="/analysts/">Analysts</a></li>
<li id="menu-item-949626" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-949626"><a href="/events/">Events</a></li>
<li id="menu-item-949625" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-949625"><a href="/reports/">Reports</a></li>
<li id="menu-item-953357" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-953357"><a href="https://gigaom.com/publishers-corner/">Publisher&#8217;s Corner</a></li>
</ul>						</nav>
						<div class="search">
									<form id="go-ossein-gcse-form" style="display: none;">
			<input id="go-ossein-gcse-query" type="search" name="search" value="" placeholder="Search" />
			<button id="go-ossein-gcse-button"><span class="goicon icon-search"></span></button>
		</form>
								</div>
					</div>
				</section>

				
									<section class="signup cf">
						<div class="wrap">
							<p><span>The industry leader in emerging technology research</span> <a href="https://gigaom.com/subscriptions/">Subscribe</a></p>
						</div>
					</section>
								</header>
					<div id="go-ossein-gcse-results-container" style="display: none;">
			<div id="go-ossein-gcse-results"></div>
		</div>
		<script type="text/x-handlebars-template" id="go-ossein-gcse-controls">
			<div class="controls">
				<a href="#close_results" class="close"><i class="goicon icon-x"></i></a>
				{{#if facets}}
					<nav class="filter">
						<ul class="facets">
							{{#each facets}}
								<li>
									{{#if this.current}}
										<span class="facet current">{{this.facet}}</span>
									{{else}}
										<a href="{{this.url}}" class="facet">{{this.facet}}</a>
									{{/if}}
								</li>
							{{/each}}
						</ul>
					</nav>
				{{/if}}
				{{#if show_results_sort}}
					<span class="results">About {{count}} {{results}}</span>
					<div class="sort">
						<label for="go-ossein-gcse-sort">Sort by</label>
						<span class="go-selectbox">
							<select name="select-example1" id="go-ossein-gcse-sort">
								{{#each sort}}
									{{#if this.current}}
										<option value="{{this.url}}" selected>{{this.sort}}</option>
									{{else}}
										<option value="{{this.url}}">{{this.sort}}</option>
									{{/if}}
								{{/each}}
							</select>
						</span>
					</div>
				{{/if}}
			</div>
		</script>
		<script type="text/x-handlebars-template" id="go-ossein-gcse-result">
			<article class="result">
				{{#if image}}
					<img src="{{image}}" alt="{{title}}" width="{{width}}" height="{{height}}" />
				{{/if}}
				<a href="{{url}}" title="{{title}}" class="title">{{{title_html}}}</a><br />
				<a href="{{url}}" title="{{title}}" class="url">{{{url_html}}}</a>
				<p class="excerpt">{{{excerpt}}}</p>
			</article>
		</script>
		<script type="text/x-handlebars-template" id="go-ossein-gcse-pagination">
			<nav class="pagination">
				<ul class="page-numbers">
					{{#if previous}}
						<li>
							<a href="{{previous}}" class="prev page-numbers">
								<i class="goicon icon-chevron-right"></i>
								<span class="button-text">Previous</span>
							</a>
						</li>
					{{/if}}
					{{#each pages}}
						<li>
							{{#if this.current}}
								<span class="page-numbers current">{{this.page}}</span>
							{{else}}
								<a href="{{this.url}}" class="page-numbers">{{this.page}}</a>
							{{/if}}
						</li>
					{{/each}}
					{{#if next}}
						<li>
							<a href="{{next}}" class="next page-numbers">
								<span class="button-text">Next</span>
								<i class="goicon icon-chevron-right"></i>
							</a>
						</li>
					{{/if}}
				</ul>
			</nav>
		</script>
		
	<div id="content">

		<div id="inner-content" class="cf">

			<main id="main" class="cf" role="main" itemscope itemprop="mainContentOfPage" itemtype="http://schema.org/Blog">
										<article id="post-953710" class="cf post-953710 post type-post status-publish format-standard has-post-thumbnail hentry tag-ai tag-gigaomai marketing-topic-big-data go-type-blog vertical-ai go_syn_media-guest-post go_syn_media-image go-post-blog featured-image-focus-center" role="article" itemscope itemprop="blogPost" itemtype="http://schema.org/BlogPosting">
									<div id="ad-a-container" class="ad go-ad ad-300x250">
			<div class="advertisement-notice">Advertisement</div>
			<div class="ad-container" id="ad-a"
				data-ad-dfp="/1008864/tech_300x250_top"
				data-ad-slot="tech_300x250_top"
				data-ad-width="300"
				data-ad-height="250"
			>
				<!-- DFP AD SLOT: tech_300x250_top -->
			</div>
		</div>
		
							<header class="article-header entry-header">
								<div class="inner-header wrap">
									<h1 class="entry-title single-title" itemprop="headline" rel="bookmark">The Future of Business is a Digital Spokesperson &mdash; Let’s Build a Preview Using Microsoft’s Bot Framework</h1>

											<p class="byline entry-meta vcard">
			<span class="by">by</span>
			<span class="entry-author author" itemprop="author" itemscope itemptype="http://schema.org/Person"><a href="https://mohritz.co/" rel="author">Chris Mohritz</a></span>
							<time class="updated entry-time" datetime="2017-06-06" itemprop="datePublished">Jun 6, 2017 - 1:37 PM CDT</time>
						</p>
		
									<p class="header-comment-count">
												<a class="comment-bubble zero" href="https://gigaom.com/2017/06/06/the-future-of-business-is-a-digital-spokesperson-lets-build-a-preview-using-microsofts-bot-framework/#respond">
			<span class="count">
				0			</span>
			<span class="text">
				Comments			</span>
		</a>
											</p>
								</div>

								
			<div class="featured-image">
				<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/chair-1850612_1920-640x426.jpg"
					srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/chair-1850612_1920-640x426.jpg 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/chair-1850612_1920-210x140.jpg 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/chair-1850612_1920-300x200.jpg 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/chair-1850612_1920-768x512.jpg 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/chair-1850612_1920-680x453.jpg 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/chair-1850612_1920-968x645.jpg 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/chair-1850612_1920-1500x999.jpg 1500w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/chair-1850612_1920-205x137.jpg 205w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/chair-1850612_1920-175x117.jpg 175w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/chair-1850612_1920-38x25.jpg 38w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/chair-1850612_1920-75x50.jpg 75w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/chair-1850612_1920-320x213.jpg 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/chair-1850612_1920-804x536.jpg 804w"
					sizes="(max-width: 50em) 87vw, 100vw"
					title="chair-1850612_1920"
					alt="">
			</div>

										</header>

							<section class="entry-content wrap cf" itemprop="articleBody">
										<ul class="social-share">
			<li class="twitter">
				<a href="https://twitter.com/intent/tweet?counturl=https%3A%2F%2Fgigaom.com%2F2017%2F06%2F06%2Fthe-future-of-business-is-a-digital-spokesperson-lets-build-a-preview-using-microsofts-bot-framework%2F&amp;text=The+Future+of+Business+is+a+Digital+Spokesperson+%E2%80%94+Let%E2%80%99s+Build+a+Preview+Using+Microsoft%E2%80%99s+Bot+Framework&amp;url=https%3A%2F%2Fgigaom.com%2F2017%2F06%2F06%2Fthe-future-of-business-is-a-digital-spokesperson-lets-build-a-preview-using-microsofts-bot-framework%2F&amp;via=Gigaom">
					<span class="goicon icon-twitter"></span> Tweet
				</a>
			</li>
			<li class="facebook">
				<a href="https://www.facebook.com/sharer/sharer.php?text=The+Future+of+Business+is+a+Digital+Spokesperson+%E2%80%94+Let%E2%80%99s+Build+a+Preview+Using+Microsoft%E2%80%99s+Bot+Framework&amp;u=https%3A%2F%2Fgigaom.com%2F2017%2F06%2F06%2Fthe-future-of-business-is-a-digital-spokesperson-lets-build-a-preview-using-microsofts-bot-framework%2F">
					<span class="goicon icon-facebook"></span> Share
				</a>
			</li>
			<li class="linkedin">
				<a href="http://www.linkedin.com/shareArticle?mini=true&amp;source=Gigaom&amp;summary=&amp;title=The+Future+of+Business+is+a+Digital+Spokesperson+%E2%80%94+Let%E2%80%99s+Build+a+Preview+Using+Microsoft%E2%80%99s+Bot+Framework&amp;url=https%3A%2F%2Fgigaom.com%2F2017%2F06%2F06%2Fthe-future-of-business-is-a-digital-spokesperson-lets-build-a-preview-using-microsofts-bot-framework%2F">
					<span class="goicon icon-linkedin"></span> Post
				</a>
			</li>
		</ul>
		<p>Everyone loves a great conversation.</p>
<p>And the <a href="https://gigaom.com/2017/03/13/unleashing-a-i-powered-conversation-with-ibm-watson/" title="Learn more about the conversational user interface">conversational U.I.</a> is coming on quickly.</p>
		<div id="ad-b-container" class="ad go-ad ad-300x250">
			<div class="advertisement-notice">Advertisement</div>
			<div class="ad-container" id="ad-b"
				data-ad-dfp="/1008864/tech_300x250_mid"
				data-ad-slot="tech_300x250_mid"
				data-ad-width="300"
				data-ad-height="250"
			>
				<!-- DFP AD SLOT: tech_300x250_mid -->
			</div>
		</div>
		
<p>Chatbots have been all the rage for the past couple of years — and the technology is quickly catching up to the hype.</p>
<p>As our trust in artificial intelligence grows, so too does our faith in letting it do more and more important work for us.</p>
<p>And what’s more important than interacting with your customers?</p>
<p>Well, A.I. is ideally suited for providing your customers with the <strong>personalized interactions</strong> they want — without you needing to hire a small army to man a call center.</p>
<h3>Rise of the Conversational U.I.</h3>
<p>The conversational user interface is about self-service — a major trend going back to ATMs. Self-service allows customers to solve problems on their own terms — while simultaneously reducing your costs.</p>
<p>The conversational U.I. is also a <strong>richer interaction</strong> — compared to websites. Providing your customers with a more natural and comfortable experience, while giving your business a deeper understanding of that customer’s emotions and urgency during the interaction.</p>
<h2>Era of the Digital Spokesperson</h2>
<p>If you project this trend out, it leads us to a point where A.I. could become the entire front end for your business. And in-fact, the consulting firm, Accenture, is already predicting exactly that.</p>
<p>Trend #1 for Accenture’s “Technology Vision 2017” is <a href="https://www.accenture.com/us-en/insight-artificial-intelligence-ui" title="Read more about A.I. is the New U.I." target="_blank">A.I. is the new U.I.</a>, anticipating…</p>
<blockquote><p>“A.I. is making every interface both simple and smart…A.I. is poised to act as the face of a company’s digital brand and a key differentiator.”</p></blockquote>
<p>So let’s explore what it takes to build out a chatbot capable of spanning the wide range of digital channels. And for the purposes of this guide, we’ll be using <a href="https://dev.botframework.com/" title="Learn more about the Microsoft Bot Framework" target="_blank">Microsoft’s Bot Framework</a> to build it.</p>
<h2>A.I.-Powered Conversational Interface</h2>
<p>Without any further ado, let’s jump right into it…</p>
<ul>
<li><a style="font-size:1.1rem;border-bottom:none;" href="#step0">What You’ll Need</a></li>
<li><a style="font-size:1.1rem;border-bottom:none;" href="#step1">Step 1: Create the Repository</a></li>
<li><a style="font-size:1.1rem;border-bottom:none;" href="#step2">Step 2: Create the Application</a></li>
<li><a style="font-size:1.1rem;border-bottom:none;" href="#step3">Step 3: Register the Bot</a></li>
<li><a style="font-size:1.1rem;border-bottom:none;" href="#step4">Step 4: Build the Bot</a></li>
<li><a style="font-size:1.1rem;border-bottom:none;" href="#step5">Step 5: Test It</a></li>
<li><a style="font-size:1.1rem;border-bottom:none;" href="#step6">Step 6: Push it to the Cloud</a></li>
<li><a style="font-size:1.1rem;border-bottom:none;" href="#step7">Step 7: Connect the Bot to Other Channels</a></li>
<li><a style="font-size:1.1rem;border-bottom:none;" href="#step8">Troubleshooting</a></li>
</ul>

<p>That may look like a lot of steps, but it’s actually pretty easy to do.</p>
<h3>The end result</h3>
<p>This guide will provide you with the <strong>perfect starting point</strong> — a simple bot, running in the cloud, that responds to your interactions.</p>
<p>What you do with it from there is where the real magic begins — adding communication channels, enhancing functionality, and deepening conversation dialog.</p>
<h4>How it works.</h4>
<p>The architecture is pretty simple, but there are a few <em>moving parts</em>.</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/Screen-Shot-2017-06-06-at-12.09.27-PM.png" alt="" width="1316" height="466" class="aligncenter size-full wp-image-953745" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/Screen-Shot-2017-06-06-at-12.09.27-PM.png 1316w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/Screen-Shot-2017-06-06-at-12.09.27-PM-300x106.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/Screen-Shot-2017-06-06-at-12.09.27-PM-768x272.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/Screen-Shot-2017-06-06-at-12.09.27-PM-680x240.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/Screen-Shot-2017-06-06-at-12.09.27-PM-968x343.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/Screen-Shot-2017-06-06-at-12.09.27-PM-210x74.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/Screen-Shot-2017-06-06-at-12.09.27-PM-71x25.png 71w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/Screen-Shot-2017-06-06-at-12.09.27-PM-141x50.png 141w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/Screen-Shot-2017-06-06-at-12.09.27-PM-320x113.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/Screen-Shot-2017-06-06-at-12.09.27-PM-640x227.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/Screen-Shot-2017-06-06-at-12.09.27-PM-804x285.png 804w" sizes="(max-width: 1316px) 100vw, 1316px">
<p>The bot itself is only a single file (written in <a href="https://nodejs.org/" title="Learn more about Node.js" target="_blank">Node.js</a>), which we will store in a <a href="https://help.github.com/articles/create-a-repo/" title="Learn more about GitHub repositories" target="_blank">GitHub repository</a>. And then we’ll use that GitHub repo as a <em>deployment source</em> for a <a href="https://azure.microsoft.com/en-us/services/app-service/web/" title="Learn more about Azure web apps" target="_blank">Web App</a> on Azure.</p>
<p>And from there, the <a href="https://docs.microsoft.com/en-us/bot-framework/dotnet/bot-builder-dotnet-connector" title="Learn more about the Connector Service" target="_blank">Bot Framework Connector Service</a> will allow you to wire up the bot to a wide range of different <a href="https://docs.microsoft.com/en-us/bot-framework/portal-configure-channels" title="Learn more about bot channels" target="_blank">communication channels</a>.</p>
<p>Ready to go? Let’s get to it…</p>
<h3 id="step0">What You’ll Need</h3>
<p>Right off the bat, let’s get the initial requirements knocked out.</p>
<h4>Install Node.js</h4>
<p>To start, this application is written in <a href="https://nodejs.org/en/download/" title="Learn more about installing Node.js" target="_blank">Node.js</a>, so you’ll need to install it. You’ll also need Node’s package manager — <code>npm</code> — which should be included with the Node.js installation.</p>
<h4>Download the source repository.</h4>
<p>Next, let’s pull down the source files. (You’ll need a <a href="https://help.github.com/articles/set-up-git/" target="_blank">git client</a> installed on your computer for this step.)</p>
<p>Move to the directory you want to use for this guide and run the following commands in a terminal:</p>
<pre rel="terminal" class="language-bash">
<code># Download source repository</code>
<code>git clone https://github.com/10xNation/microsoft-bot-framework-nodejs.git</code>
<code>cd microsoft-bot-framework-nodejs</code>
</pre>
<p>The repository only includes a couple of files — so don’t blink.</p>
<h4>Create an Azure account.</h4>
<p>Go to the <a href="https://azure.microsoft.com/" target="_blank">Azure home page</a> (Azure is Microsoft’s cloud services platform).</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/2microsoft-azure-home.png" alt="" width="1000" height="500" class="aligncenter size-full wp-image-953744" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/2microsoft-azure-home.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/2microsoft-azure-home-300x150.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/2microsoft-azure-home-768x384.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/2microsoft-azure-home-680x340.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/2microsoft-azure-home-968x484.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/2microsoft-azure-home-210x105.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/2microsoft-azure-home-50x25.png 50w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/2microsoft-azure-home-100x50.png 100w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/2microsoft-azure-home-320x160.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/2microsoft-azure-home-640x320.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/2microsoft-azure-home-804x402.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>If you don’t already have an Azure account, go ahead and create one by clicking on the “Free Account” button and completing the registration process.</p>
<h4 id="step0c">Install the Bot Framework emulator.</h4>
<p>You’ll also need to install the <a href="https://github.com/Microsoft/BotFramework-Emulator" title="Learn more about the Bot Framework emulator" target="_blank">Bot Framework emulator</a>.</p>
<p>The emulator is a desktop application that allows you to test and debug bots on your local machine (or via tunnel). It runs on Windows, Mac, and Linux. Just follow the provided directions to install — it’s super easy to use.</p>
<h3 id="step1">Step 1: Create the Repository</h3>
<p>Next, go to the <a href="https://github.com/" title="GitHub" target="_blank">GitHub home page</a> and register for a new account if you don’t already have one.</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/3github-dashboard-new-repo.png" alt="" width="1000" height="489" class="aligncenter size-full wp-image-953743" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/3github-dashboard-new-repo.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/3github-dashboard-new-repo-300x147.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/3github-dashboard-new-repo-768x376.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/3github-dashboard-new-repo-680x333.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/3github-dashboard-new-repo-968x473.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/3github-dashboard-new-repo-210x103.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/3github-dashboard-new-repo-51x25.png 51w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/3github-dashboard-new-repo-102x50.png 102w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/3github-dashboard-new-repo-320x156.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/3github-dashboard-new-repo-640x313.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/3github-dashboard-new-repo-804x393.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>Once you’re signed in, click on the <em>plus sign</em> and “New repository.”</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/4github-new-repo-microsoft-bot-framework-nodejs.png" alt="" width="1000" height="552" class="aligncenter size-full wp-image-953742" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/4github-new-repo-microsoft-bot-framework-nodejs.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/4github-new-repo-microsoft-bot-framework-nodejs-300x166.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/4github-new-repo-microsoft-bot-framework-nodejs-768x424.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/4github-new-repo-microsoft-bot-framework-nodejs-680x375.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/4github-new-repo-microsoft-bot-framework-nodejs-968x534.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/4github-new-repo-microsoft-bot-framework-nodejs-210x116.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/4github-new-repo-microsoft-bot-framework-nodejs-45x25.png 45w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/4github-new-repo-microsoft-bot-framework-nodejs-91x50.png 91w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/4github-new-repo-microsoft-bot-framework-nodejs-320x177.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/4github-new-repo-microsoft-bot-framework-nodejs-640x353.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/4github-new-repo-microsoft-bot-framework-nodejs-804x444.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>Enter a name for your new repo and hit “Create repository.”</p>
<p>Next, we’ll spin up the app…</p>
<h3 id="step2">Step 2: Create the Application</h3>
<p>We need an Azure’s Web App instance to power the bot in the cloud, so go to your <a href="http://portal.azure.com/" target="_blank">Azure Dashboard</a> and sign in with your Azure account.</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/5microsoft-azure-dashboard.png" alt="" width="1354" height="696" class="aligncenter size-full wp-image-953741" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/5microsoft-azure-dashboard.png 1354w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/5microsoft-azure-dashboard-300x154.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/5microsoft-azure-dashboard-768x395.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/5microsoft-azure-dashboard-680x350.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/5microsoft-azure-dashboard-968x498.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/5microsoft-azure-dashboard-210x108.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/5microsoft-azure-dashboard-49x25.png 49w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/5microsoft-azure-dashboard-97x50.png 97w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/5microsoft-azure-dashboard-320x164.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/5microsoft-azure-dashboard-640x329.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/5microsoft-azure-dashboard-804x413.png 804w" sizes="(max-width: 1354px) 100vw, 1354px">
<p>Click on the “+ New” button.</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/6microsoft-azure-new-web-mobile-web-app.png" alt="" width="1000" height="485" class="aligncenter size-full wp-image-953740" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/6microsoft-azure-new-web-mobile-web-app.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/6microsoft-azure-new-web-mobile-web-app-300x146.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/6microsoft-azure-new-web-mobile-web-app-768x372.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/6microsoft-azure-new-web-mobile-web-app-680x330.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/6microsoft-azure-new-web-mobile-web-app-968x469.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/6microsoft-azure-new-web-mobile-web-app-210x102.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/6microsoft-azure-new-web-mobile-web-app-52x25.png 52w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/6microsoft-azure-new-web-mobile-web-app-103x50.png 103w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/6microsoft-azure-new-web-mobile-web-app-320x155.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/6microsoft-azure-new-web-mobile-web-app-640x310.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/6microsoft-azure-new-web-mobile-web-app-804x390.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>Then select the “Web + Mobile” and “Web App“ options.</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/7microsoft-azure-new-web-mobile-web-app-configure.png" alt="" width="1000" height="486" class="aligncenter size-full wp-image-953739" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/7microsoft-azure-new-web-mobile-web-app-configure.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/7microsoft-azure-new-web-mobile-web-app-configure-300x146.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/7microsoft-azure-new-web-mobile-web-app-configure-768x373.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/7microsoft-azure-new-web-mobile-web-app-configure-680x330.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/7microsoft-azure-new-web-mobile-web-app-configure-968x470.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/7microsoft-azure-new-web-mobile-web-app-configure-210x102.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/7microsoft-azure-new-web-mobile-web-app-configure-51x25.png 51w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/7microsoft-azure-new-web-mobile-web-app-configure-103x50.png 103w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/7microsoft-azure-new-web-mobile-web-app-configure-320x156.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/7microsoft-azure-new-web-mobile-web-app-configure-640x311.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/7microsoft-azure-new-web-mobile-web-app-configure-804x391.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>On the Web App Create page, enter an “App name” — select a “Subscription,” — then create or select a “Resource group.” And the system should automatically create/choose an “App Service plan/Location“ for you.</p>
<p>Once everything is filled out, hit “Create.”</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/8microsoft-azure-new-web-mobile-web-app-dashboard.png" alt="" width="1000" height="496" class="aligncenter size-full wp-image-953738" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/8microsoft-azure-new-web-mobile-web-app-dashboard.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/8microsoft-azure-new-web-mobile-web-app-dashboard-300x149.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/8microsoft-azure-new-web-mobile-web-app-dashboard-768x381.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/8microsoft-azure-new-web-mobile-web-app-dashboard-680x337.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/8microsoft-azure-new-web-mobile-web-app-dashboard-968x480.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/8microsoft-azure-new-web-mobile-web-app-dashboard-210x104.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/8microsoft-azure-new-web-mobile-web-app-dashboard-50x25.png 50w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/8microsoft-azure-new-web-mobile-web-app-dashboard-101x50.png 101w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/8microsoft-azure-new-web-mobile-web-app-dashboard-320x159.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/8microsoft-azure-new-web-mobile-web-app-dashboard-640x317.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/8microsoft-azure-new-web-mobile-web-app-dashboard-804x399.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>And after a few minutes, the new subscription will show up on your dashboard. Go ahead and click it (the App Service).</p>
<h4 id="step2a">Configure the deployment options.</h4>
<p>That should take you to the Overview tab for your new app.</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/9microsoft-azure-web-app-dashboard.png" alt="" width="1000" height="496" class="aligncenter size-full wp-image-953737" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/9microsoft-azure-web-app-dashboard.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/9microsoft-azure-web-app-dashboard-300x149.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/9microsoft-azure-web-app-dashboard-768x381.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/9microsoft-azure-web-app-dashboard-680x337.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/9microsoft-azure-web-app-dashboard-968x480.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/9microsoft-azure-web-app-dashboard-210x104.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/9microsoft-azure-web-app-dashboard-50x25.png 50w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/9microsoft-azure-web-app-dashboard-101x50.png 101w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/9microsoft-azure-web-app-dashboard-320x159.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/9microsoft-azure-web-app-dashboard-640x317.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/9microsoft-azure-web-app-dashboard-804x399.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>Click on the “Deployment options” tab.</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/10microsoft-azure-web-app-deployment-options.png" alt="" width="1000" height="486" class="aligncenter size-full wp-image-953736" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/10microsoft-azure-web-app-deployment-options.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/10microsoft-azure-web-app-deployment-options-300x146.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/10microsoft-azure-web-app-deployment-options-768x373.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/10microsoft-azure-web-app-deployment-options-680x330.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/10microsoft-azure-web-app-deployment-options-968x470.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/10microsoft-azure-web-app-deployment-options-210x102.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/10microsoft-azure-web-app-deployment-options-51x25.png 51w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/10microsoft-azure-web-app-deployment-options-103x50.png 103w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/10microsoft-azure-web-app-deployment-options-320x156.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/10microsoft-azure-web-app-deployment-options-640x311.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/10microsoft-azure-web-app-deployment-options-804x391.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>And then click on “GitHub.”</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/11microsoft-azure-web-app-deployment-options-github.png" alt="" width="1000" height="487" class="aligncenter size-full wp-image-953735" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/11microsoft-azure-web-app-deployment-options-github.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/11microsoft-azure-web-app-deployment-options-github-300x146.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/11microsoft-azure-web-app-deployment-options-github-768x374.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/11microsoft-azure-web-app-deployment-options-github-680x331.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/11microsoft-azure-web-app-deployment-options-github-968x471.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/11microsoft-azure-web-app-deployment-options-github-210x102.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/11microsoft-azure-web-app-deployment-options-github-51x25.png 51w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/11microsoft-azure-web-app-deployment-options-github-103x50.png 103w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/11microsoft-azure-web-app-deployment-options-github-320x156.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/11microsoft-azure-web-app-deployment-options-github-640x312.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/11microsoft-azure-web-app-deployment-options-github-804x392.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>Go ahead and follow the prompts to authorize Azure to access your GitHub account / organization.</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/12microsoft-azure-web-app-deployment-options-github-ok.png" alt="" width="1000" height="484" class="aligncenter size-full wp-image-953734" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/12microsoft-azure-web-app-deployment-options-github-ok.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/12microsoft-azure-web-app-deployment-options-github-ok-300x145.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/12microsoft-azure-web-app-deployment-options-github-ok-768x372.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/12microsoft-azure-web-app-deployment-options-github-ok-680x329.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/12microsoft-azure-web-app-deployment-options-github-ok-968x469.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/12microsoft-azure-web-app-deployment-options-github-ok-210x102.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/12microsoft-azure-web-app-deployment-options-github-ok-52x25.png 52w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/12microsoft-azure-web-app-deployment-options-github-ok-103x50.png 103w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/12microsoft-azure-web-app-deployment-options-github-ok-320x155.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/12microsoft-azure-web-app-deployment-options-github-ok-640x310.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/12microsoft-azure-web-app-deployment-options-github-ok-804x389.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>And hit “OK”</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/13microsoft-azure-web-app-deployment-options-github-choose-repo.png" alt="" width="1000" height="486" class="aligncenter size-full wp-image-953733" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/13microsoft-azure-web-app-deployment-options-github-choose-repo.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/13microsoft-azure-web-app-deployment-options-github-choose-repo-300x146.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/13microsoft-azure-web-app-deployment-options-github-choose-repo-768x373.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/13microsoft-azure-web-app-deployment-options-github-choose-repo-680x330.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/13microsoft-azure-web-app-deployment-options-github-choose-repo-968x470.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/13microsoft-azure-web-app-deployment-options-github-choose-repo-210x102.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/13microsoft-azure-web-app-deployment-options-github-choose-repo-51x25.png 51w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/13microsoft-azure-web-app-deployment-options-github-choose-repo-103x50.png 103w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/13microsoft-azure-web-app-deployment-options-github-choose-repo-320x156.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/13microsoft-azure-web-app-deployment-options-github-choose-repo-640x311.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/13microsoft-azure-web-app-deployment-options-github-choose-repo-804x391.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>Hit “Choose project” and select the repo you created in <a href="#step1">step #1</a>. If desired, select a branch — we’ll stick with <code>master</code> for this demo.</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/14microsoft-azure-web-app-deployment-options-github-configure.png" alt="" width="1000" height="486" class="aligncenter size-full wp-image-953732" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/14microsoft-azure-web-app-deployment-options-github-configure.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/14microsoft-azure-web-app-deployment-options-github-configure-300x146.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/14microsoft-azure-web-app-deployment-options-github-configure-768x373.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/14microsoft-azure-web-app-deployment-options-github-configure-680x330.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/14microsoft-azure-web-app-deployment-options-github-configure-968x470.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/14microsoft-azure-web-app-deployment-options-github-configure-210x102.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/14microsoft-azure-web-app-deployment-options-github-configure-51x25.png 51w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/14microsoft-azure-web-app-deployment-options-github-configure-103x50.png 103w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/14microsoft-azure-web-app-deployment-options-github-configure-320x156.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/14microsoft-azure-web-app-deployment-options-github-configure-640x311.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/14microsoft-azure-web-app-deployment-options-github-configure-804x391.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>Once the GitHub repo is fully configured, click “OK.”</p>
<p>And that’s it for the web app, so let’s spin up the bot…</p>
<h3 id="step3">Step 3: Register the Bot</h3>
<p>For your bot to be publicly accessible, you’ll need to register it with the Bot Framework platform, so go to the <a href="https://dev.botframework.com/" title="Bot Framework development page" target="_blank">Developer Portal</a> and sign in with your Microsoft account (same as Azure portal above).</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/15microsoft-bot-framework-development-dashboard.png" alt="" width="1000" height="498" class="aligncenter size-full wp-image-953731" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/15microsoft-bot-framework-development-dashboard.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/15microsoft-bot-framework-development-dashboard-300x149.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/15microsoft-bot-framework-development-dashboard-768x382.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/15microsoft-bot-framework-development-dashboard-680x339.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/15microsoft-bot-framework-development-dashboard-968x482.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/15microsoft-bot-framework-development-dashboard-210x105.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/15microsoft-bot-framework-development-dashboard-50x25.png 50w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/15microsoft-bot-framework-development-dashboard-100x50.png 100w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/15microsoft-bot-framework-development-dashboard-320x159.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/15microsoft-bot-framework-development-dashboard-640x319.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/15microsoft-bot-framework-development-dashboard-804x400.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>Click on “My Bots.”</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/16microsoft-bot-framework-development-my-bots.png" alt="" width="1000" height="371" class="aligncenter size-full wp-image-953730" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/16microsoft-bot-framework-development-my-bots.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/16microsoft-bot-framework-development-my-bots-300x111.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/16microsoft-bot-framework-development-my-bots-768x285.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/16microsoft-bot-framework-development-my-bots-680x252.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/16microsoft-bot-framework-development-my-bots-968x359.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/16microsoft-bot-framework-development-my-bots-210x78.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/16microsoft-bot-framework-development-my-bots-67x25.png 67w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/16microsoft-bot-framework-development-my-bots-135x50.png 135w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/16microsoft-bot-framework-development-my-bots-320x119.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/16microsoft-bot-framework-development-my-bots-640x237.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/16microsoft-bot-framework-development-my-bots-804x298.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>And “Register.”</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/17microsoft-azure-web-app-dashboard-url.png" alt="" width="1000" height="496" class="aligncenter size-full wp-image-953729" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/17microsoft-azure-web-app-dashboard-url.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/17microsoft-azure-web-app-dashboard-url-300x149.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/17microsoft-azure-web-app-dashboard-url-768x381.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/17microsoft-azure-web-app-dashboard-url-680x337.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/17microsoft-azure-web-app-dashboard-url-968x480.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/17microsoft-azure-web-app-dashboard-url-210x104.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/17microsoft-azure-web-app-dashboard-url-50x25.png 50w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/17microsoft-azure-web-app-dashboard-url-101x50.png 101w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/17microsoft-azure-web-app-dashboard-url-320x159.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/17microsoft-azure-web-app-dashboard-url-640x317.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/17microsoft-azure-web-app-dashboard-url-804x399.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>Then jump back to your Azure App Service Overview tab from <a href="#step2">step #2</a> and copy the “URL.” Paste that URL into the “Messaging endpoint” field and add on <code>/api/messages</code> (see below).</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/18microsoft-bot-framework-development-my-bots-new.png" alt="" width="1000" height="1442" class="aligncenter size-full wp-image-953728" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/18microsoft-bot-framework-development-my-bots-new.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/18microsoft-bot-framework-development-my-bots-new-208x300.png 208w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/18microsoft-bot-framework-development-my-bots-new-768x1107.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/18microsoft-bot-framework-development-my-bots-new-472x680.png 472w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/18microsoft-bot-framework-development-my-bots-new-968x1396.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/18microsoft-bot-framework-development-my-bots-new-97x140.png 97w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/18microsoft-bot-framework-development-my-bots-new-17x25.png 17w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/18microsoft-bot-framework-development-my-bots-new-35x50.png 35w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/18microsoft-bot-framework-development-my-bots-new-300x433.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/18microsoft-bot-framework-development-my-bots-new-320x461.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/18microsoft-bot-framework-development-my-bots-new-640x923.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/18microsoft-bot-framework-development-my-bots-new-804x1159.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>Also enter a “Display name,” “Bot handle,” and “Long description.” Then click on “Create Microsoft App ID and password” to get your app ID.</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/19microsoft-bot-framework-development-generate-app-id-1.png" alt="" width="1000" height="278" class="aligncenter size-full wp-image-953727" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/19microsoft-bot-framework-development-generate-app-id-1.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/19microsoft-bot-framework-development-generate-app-id-1-300x83.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/19microsoft-bot-framework-development-generate-app-id-1-768x214.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/19microsoft-bot-framework-development-generate-app-id-1-680x189.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/19microsoft-bot-framework-development-generate-app-id-1-968x269.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/19microsoft-bot-framework-development-generate-app-id-1-210x58.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/19microsoft-bot-framework-development-generate-app-id-1-90x25.png 90w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/19microsoft-bot-framework-development-generate-app-id-1-180x50.png 180w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/19microsoft-bot-framework-development-generate-app-id-1-320x89.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/19microsoft-bot-framework-development-generate-app-id-1-640x178.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/19microsoft-bot-framework-development-generate-app-id-1-804x224.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>Click on “Generate an app password to continue.”</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/20microsoft-bot-framework-development-generate-app-id-2.png" alt="" width="1000" height="278" class="aligncenter size-full wp-image-953726" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/20microsoft-bot-framework-development-generate-app-id-2.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/20microsoft-bot-framework-development-generate-app-id-2-300x83.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/20microsoft-bot-framework-development-generate-app-id-2-768x214.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/20microsoft-bot-framework-development-generate-app-id-2-680x189.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/20microsoft-bot-framework-development-generate-app-id-2-968x269.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/20microsoft-bot-framework-development-generate-app-id-2-210x58.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/20microsoft-bot-framework-development-generate-app-id-2-90x25.png 90w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/20microsoft-bot-framework-development-generate-app-id-2-180x50.png 180w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/20microsoft-bot-framework-development-generate-app-id-2-320x89.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/20microsoft-bot-framework-development-generate-app-id-2-640x178.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/20microsoft-bot-framework-development-generate-app-id-2-804x224.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>And “Ok.”</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/21microsoft-bot-framework-development-generate-app-id-3.png" alt="" width="1000" height="359" class="aligncenter size-full wp-image-953725" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/21microsoft-bot-framework-development-generate-app-id-3.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/21microsoft-bot-framework-development-generate-app-id-3-300x108.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/21microsoft-bot-framework-development-generate-app-id-3-768x276.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/21microsoft-bot-framework-development-generate-app-id-3-680x244.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/21microsoft-bot-framework-development-generate-app-id-3-968x348.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/21microsoft-bot-framework-development-generate-app-id-3-210x75.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/21microsoft-bot-framework-development-generate-app-id-3-70x25.png 70w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/21microsoft-bot-framework-development-generate-app-id-3-139x50.png 139w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/21microsoft-bot-framework-development-generate-app-id-3-320x115.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/21microsoft-bot-framework-development-generate-app-id-3-640x230.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/21microsoft-bot-framework-development-generate-app-id-3-804x289.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>Then “Finish and go back to Bot Framework.” And that will take you back to the Bot registration page with a pre-populated “app ID.”</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/22microsoft-bot-framework-development-my-bots-new-id.png" alt="" width="1000" height="1442" class="aligncenter size-full wp-image-953724" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/22microsoft-bot-framework-development-my-bots-new-id.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/22microsoft-bot-framework-development-my-bots-new-id-208x300.png 208w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/22microsoft-bot-framework-development-my-bots-new-id-768x1107.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/22microsoft-bot-framework-development-my-bots-new-id-472x680.png 472w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/22microsoft-bot-framework-development-my-bots-new-id-968x1396.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/22microsoft-bot-framework-development-my-bots-new-id-97x140.png 97w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/22microsoft-bot-framework-development-my-bots-new-id-17x25.png 17w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/22microsoft-bot-framework-development-my-bots-new-id-35x50.png 35w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/22microsoft-bot-framework-development-my-bots-new-id-300x433.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/22microsoft-bot-framework-development-my-bots-new-id-320x461.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/22microsoft-bot-framework-development-my-bots-new-id-640x923.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/22microsoft-bot-framework-development-my-bots-new-id-804x1159.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>All you have to do now is verify your email address in the “Owners” box, agree to the terms statement, and hit “Register.”</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/23microsoft-bot-framework-development-my-bots-new-confirmation.png" alt="" width="1000" height="374" class="aligncenter size-full wp-image-953723" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/23microsoft-bot-framework-development-my-bots-new-confirmation.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/23microsoft-bot-framework-development-my-bots-new-confirmation-300x112.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/23microsoft-bot-framework-development-my-bots-new-confirmation-768x287.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/23microsoft-bot-framework-development-my-bots-new-confirmation-680x254.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/23microsoft-bot-framework-development-my-bots-new-confirmation-968x362.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/23microsoft-bot-framework-development-my-bots-new-confirmation-210x79.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/23microsoft-bot-framework-development-my-bots-new-confirmation-67x25.png 67w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/23microsoft-bot-framework-development-my-bots-new-confirmation-134x50.png 134w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/23microsoft-bot-framework-development-my-bots-new-confirmation-320x120.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/23microsoft-bot-framework-development-my-bots-new-confirmation-640x239.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/23microsoft-bot-framework-development-my-bots-new-confirmation-804x301.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>That should give you a simple success prompt. So hit “OK.”</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/24microsoft-bot-framework-development-bot-dashboard.png" alt="" width="1000" height="605" class="aligncenter size-full wp-image-953722" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/24microsoft-bot-framework-development-bot-dashboard.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/24microsoft-bot-framework-development-bot-dashboard-300x182.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/24microsoft-bot-framework-development-bot-dashboard-768x465.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/24microsoft-bot-framework-development-bot-dashboard-680x411.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/24microsoft-bot-framework-development-bot-dashboard-968x586.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/24microsoft-bot-framework-development-bot-dashboard-210x127.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/24microsoft-bot-framework-development-bot-dashboard-41x25.png 41w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/24microsoft-bot-framework-development-bot-dashboard-83x50.png 83w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/24microsoft-bot-framework-development-bot-dashboard-320x194.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/24microsoft-bot-framework-development-bot-dashboard-640x387.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/24microsoft-bot-framework-development-bot-dashboard-804x486.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>And at this point you should see a dashboard for your shiny new bot.</p>
<p>So let’s put down some code for this new bot…</p>
<h3 id="step4">Step 4: Build the Bot</h3>
<p>When it comes to software development, this is about as easy as it gets.</p>
<h4>Configure Node.js.</h4>
<p>Spin up the application settings using the command below:</p>
<h5>Terminal</h5>
<pre>
<code>npm init</code>
</pre>
<p>Enter responses to the screen prompts as desired — defaults are fine.</p>
<h4>Install the Node.js modules.</h4>
<p>Next, let’s install the Node.js requirements:</p>
<h5>Terminal</h5>
<pre>
<code>npm install --save botbuilder</code>
<code>npm install --save restify</code>
</pre>
<p>That should only take a few seconds, so let’s move onto where the magic really happens…</p>
<h4>Create the bot application.</h4>
<p>The repo you cloned in <a href="step0">What You’ll Need</a> already includes this file, but below is the code if you’d like to see a preview:</p>
<h5>app.js</h5>
<pre>
<code>var restify = require('restify');</code>
<code>var builder = require('botbuilder');</code>

<code>// Setup Restify Server</code>
<code>var server = restify.createServer();</code>
<code>server.listen(process.env.port || process.env.PORT || 3978, function () {</code>
<code>  console.log('%s listening to %s', server.name, server.url);</code>
<code>});</code>

<code>// Create chat connector for communicating with the Bot Framework Service</code>
<code>var connector = new builder.ChatConnector({</code>
<code>  appId: process.env.MICROSOFT_APP_ID,</code>
<code>  appPassword: process.env.MICROSOFT_APP_PASSWORD</code>
<code>});</code>

<code>// Listen for messages from users</code>
<code>server.post('/api/messages', connector.listen());</code>

<code>// Receive messages from the user and respond by echoing each message back (prefixed with 'You said:')</code>
<code>var bot = new builder.UniversalBot(connector, function (session) {</code>
<code>  session.send("You said: %s", session.message.text);</code>
<code>});</code>
</pre>
<p>Ready to see the bot in action?</p>
<h3 id="step5">Step 5: Test It</h3>
<p>Then let’s test your bot by using the emulator you installed in <a href="#step0c">What You’ll Need</a>.</p>
<h4>Start the bot.</h4>
<p>Move to the repo directory from <a href="#step0">What You’ll Need</a> and run the following command in a terminal to start your bot:</p>
<h5>Terminal</h5>
<pre>
<code>node app.js</code>
</pre>
<p>This will run the application on the port we listed in app.js file — 3978.</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/25microsoft-bot-framework-bot-terminal.png" alt="" width="602" height="334" class="aligncenter size-full wp-image-953721" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/25microsoft-bot-framework-bot-terminal.png 602w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/25microsoft-bot-framework-bot-terminal-300x166.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/25microsoft-bot-framework-bot-terminal-600x334.png 600w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/25microsoft-bot-framework-bot-terminal-210x117.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/25microsoft-bot-framework-bot-terminal-45x25.png 45w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/25microsoft-bot-framework-bot-terminal-90x50.png 90w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/25microsoft-bot-framework-bot-terminal-320x178.png 320w" sizes="(max-width: 602px) 100vw, 602px">
<p>All you’ll see is a simple listening notice.</p>
<h4>Connect to the emulator.</h4>
<p>Once your bot is running, fire up the bot emulator and enter the URL<br><code>http://127.0.0.1:3978/api/messages</code>, and your App ID and password.</p>
<p></p>

<center><img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/26microsoft-bot-framework-emulator-connect.png" alt="" width="800" height="601" class="aligncenter size-full wp-image-953720" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/26microsoft-bot-framework-emulator-connect.png 800w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/26microsoft-bot-framework-emulator-connect-300x225.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/26microsoft-bot-framework-emulator-connect-768x577.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/26microsoft-bot-framework-emulator-connect-680x511.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/26microsoft-bot-framework-emulator-connect-186x140.png 186w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/26microsoft-bot-framework-emulator-connect-33x25.png 33w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/26microsoft-bot-framework-emulator-connect-67x50.png 67w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/26microsoft-bot-framework-emulator-connect-320x240.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/26microsoft-bot-framework-emulator-connect-640x481.png 640w" sizes="(max-width: 800px) 100vw, 800px"></center>
<p>Then hit “Connect.”</p>
<h4>Have a chat.</h4>
<p>Now that your bot is running locally and is connected to the emulator, try out your bot by typing a few messages in the emulator.</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/27microsoft-bot-framework-emulator-response.png" alt="" width="799" height="623" class="aligncenter size-full wp-image-953719" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/27microsoft-bot-framework-emulator-response.png 799w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/27microsoft-bot-framework-emulator-response-300x234.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/27microsoft-bot-framework-emulator-response-768x599.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/27microsoft-bot-framework-emulator-response-680x530.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/27microsoft-bot-framework-emulator-response-180x140.png 180w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/27microsoft-bot-framework-emulator-response-32x25.png 32w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/27microsoft-bot-framework-emulator-response-64x50.png 64w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/27microsoft-bot-framework-emulator-response-320x250.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/27microsoft-bot-framework-emulator-response-640x499.png 640w" sizes="(max-width: 799px) 100vw, 799px">
<p>If all went as planned, you should see the bot respond to each of your messages with the original message prefixed with “You said:”.</p>
<h3 id="step6">Step 6: Push it to the Cloud</h3>
<p>Now we’re ready to publish the bot to Azure.</p>
<h4>Upload the repository</h4>
<p>And the easiest way to do that is to delete the <code>.git</code> folder in the repo you cloned in <a href="#step0">What You’ll Need</a>, then reinitialize it as a new repo.</p>
<p>So go ahead and delete <code>.git</code> and run the following commands in the repo’s directory:</p>
<pre>
<code>git init</code>
<code>git add .</code>
<code>git commit -m "Initial commit"</code>
<code>git remote add origin git@github.com:PROFILE/REPO_NAME.git</code>
<code>git push -u origin master</code>
</pre>
<p>Replace <code>PROFILE</code> and <code>REPO_NAME</code> with the respective profile/organization and repository name you created in <a href="#step1">step #1</a>.</p>
<p style="font-style:italic;">Note: if you chose a branch other than <code>master</code> while configuring the “Deployment options” in <a href="#step2a">step 2</a>, then replace <code>master</code> above with the appropriate branch.</p>
<h4>Set the environment variables.</h4>
<p>To keep things secure, you’ll need to add your App ID and password to the Web App settings, so they don’t have to be configured in the <code>app.js</code> file (and publicly available on github.com).</p>
<p>Jump back to your Azure Web App dashboard from <a href="#step2">step #2</a> and click on the “Application settings” tab, then scroll down to the “App settings” section.</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/28microsoft-azure-web-app-environment-settings-bot.png" alt="" width="1000" height="497" class="aligncenter size-full wp-image-953718" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/28microsoft-azure-web-app-environment-settings-bot.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/28microsoft-azure-web-app-environment-settings-bot-300x149.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/28microsoft-azure-web-app-environment-settings-bot-768x382.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/28microsoft-azure-web-app-environment-settings-bot-680x338.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/28microsoft-azure-web-app-environment-settings-bot-968x481.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/28microsoft-azure-web-app-environment-settings-bot-210x104.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/28microsoft-azure-web-app-environment-settings-bot-50x25.png 50w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/28microsoft-azure-web-app-environment-settings-bot-101x50.png 101w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/28microsoft-azure-web-app-environment-settings-bot-320x159.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/28microsoft-azure-web-app-environment-settings-bot-640x318.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/28microsoft-azure-web-app-environment-settings-bot-804x400.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>We need to add two environment variables: For the first one, enter “MICROSOFT_APP_ID” for <code>Key</code> and your App ID from <a href="#step3">step #3</a> in the <code>Value</code> field. And for the second one, enter “MICROSOFT_APP_PASSWORD” for <code>Key</code> and your respective app password for <code>Value</code>.</p>
<p>Then hit the “Save” button.</p>
<h4>Verify deployment.</h4>
<p>Once Azure finishes reconfiguring itself, you should be able to see your bot on the <a href="https://dev.botframework.com/bots" title="Go to your dashboard" target="_blank">My Bots Dashboard</a>.</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/29microsoft-bot-framework-deployment-verify.png" alt="" width="1000" height="240" class="aligncenter size-full wp-image-953717" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/29microsoft-bot-framework-deployment-verify.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/29microsoft-bot-framework-deployment-verify-300x72.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/29microsoft-bot-framework-deployment-verify-768x184.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/29microsoft-bot-framework-deployment-verify-680x163.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/29microsoft-bot-framework-deployment-verify-968x232.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/29microsoft-bot-framework-deployment-verify-210x50.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/29microsoft-bot-framework-deployment-verify-104x25.png 104w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/29microsoft-bot-framework-deployment-verify-208x50.png 208w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/29microsoft-bot-framework-deployment-verify-320x77.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/29microsoft-bot-framework-deployment-verify-640x154.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/29microsoft-bot-framework-deployment-verify-804x193.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>Click on it.</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/30microsoft-bot-framework-deployment-test.png" alt="" width="1000" height="513" class="aligncenter size-full wp-image-953716" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/30microsoft-bot-framework-deployment-test.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/30microsoft-bot-framework-deployment-test-300x154.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/30microsoft-bot-framework-deployment-test-768x394.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/30microsoft-bot-framework-deployment-test-680x349.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/30microsoft-bot-framework-deployment-test-968x497.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/30microsoft-bot-framework-deployment-test-210x108.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/30microsoft-bot-framework-deployment-test-49x25.png 49w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/30microsoft-bot-framework-deployment-test-97x50.png 97w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/30microsoft-bot-framework-deployment-test-320x164.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/30microsoft-bot-framework-deployment-test-640x328.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/30microsoft-bot-framework-deployment-test-804x412.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>Then click on “Test” and enter something in the message box.</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/31microsoft-bot-framework-deployment-test-response.png" alt="" width="1000" height="515" class="aligncenter size-full wp-image-953715" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/31microsoft-bot-framework-deployment-test-response.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/31microsoft-bot-framework-deployment-test-response-300x155.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/31microsoft-bot-framework-deployment-test-response-768x396.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/31microsoft-bot-framework-deployment-test-response-680x350.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/31microsoft-bot-framework-deployment-test-response-968x499.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/31microsoft-bot-framework-deployment-test-response-210x108.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/31microsoft-bot-framework-deployment-test-response-49x25.png 49w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/31microsoft-bot-framework-deployment-test-response-97x50.png 97w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/31microsoft-bot-framework-deployment-test-response-320x165.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/31microsoft-bot-framework-deployment-test-response-640x330.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/31microsoft-bot-framework-deployment-test-response-804x414.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>You should see a response similar to what you got in the emulator above.</p>
<p>Good stuff!</p>
<h3 id="step7">Step 7: Connect the Bot to Other Channels</h3>
<p>One of the biggest advantages of using the Bot Framework is the ease at which you can make your bot available on nearly all of the major chat platforms — so take advantage!</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/32microsoft-bot-framework-add-channels.png" alt="" width="1000" height="426" class="aligncenter size-full wp-image-953714" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/32microsoft-bot-framework-add-channels.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/32microsoft-bot-framework-add-channels-300x128.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/32microsoft-bot-framework-add-channels-768x327.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/32microsoft-bot-framework-add-channels-680x290.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/32microsoft-bot-framework-add-channels-968x412.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/32microsoft-bot-framework-add-channels-210x89.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/32microsoft-bot-framework-add-channels-59x25.png 59w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/32microsoft-bot-framework-add-channels-117x50.png 117w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/32microsoft-bot-framework-add-channels-320x136.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/32microsoft-bot-framework-add-channels-640x273.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/32microsoft-bot-framework-add-channels-804x343.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>Simply click on whichever channel you want to add and follow the prompts.</p>
<p>That’s it!</p>
<h3 id="step8">Troubleshooting</h3>
<p>If you’re having any problems with the application, be sure to check out the logs.</p>
<h4>Emulator logs.</h4>
<p>The emulator makes it pretty easy to track what’s happening.</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/33microsoft-bot-framework-emulator-logs.png" alt="" width="1000" height="543" class="aligncenter size-full wp-image-953713" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/33microsoft-bot-framework-emulator-logs.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/33microsoft-bot-framework-emulator-logs-300x163.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/33microsoft-bot-framework-emulator-logs-768x417.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/33microsoft-bot-framework-emulator-logs-680x369.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/33microsoft-bot-framework-emulator-logs-968x526.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/33microsoft-bot-framework-emulator-logs-210x114.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/33microsoft-bot-framework-emulator-logs-46x25.png 46w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/33microsoft-bot-framework-emulator-logs-92x50.png 92w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/33microsoft-bot-framework-emulator-logs-320x174.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/33microsoft-bot-framework-emulator-logs-640x348.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/33microsoft-bot-framework-emulator-logs-804x437.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>Take a look in the “Log” section of your emulator for specifics.</p>
<h4>Azure logs.</h4>
<p>Within Azure, jump back to your dashboard and click on the “Diagnose and solve problems” tab.</p>
<img src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/34microsoft-azure-web-app-logs-bot-framework.png" alt="" width="1000" height="502" class="aligncenter size-full wp-image-953712" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/34microsoft-azure-web-app-logs-bot-framework.png 1000w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/34microsoft-azure-web-app-logs-bot-framework-300x151.png 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/34microsoft-azure-web-app-logs-bot-framework-768x386.png 768w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/34microsoft-azure-web-app-logs-bot-framework-680x341.png 680w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/34microsoft-azure-web-app-logs-bot-framework-968x486.png 968w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/34microsoft-azure-web-app-logs-bot-framework-210x105.png 210w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/34microsoft-azure-web-app-logs-bot-framework-50x25.png 50w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/34microsoft-azure-web-app-logs-bot-framework-100x50.png 100w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/34microsoft-azure-web-app-logs-bot-framework-320x161.png 320w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/34microsoft-azure-web-app-logs-bot-framework-640x321.png 640w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/34microsoft-azure-web-app-logs-bot-framework-804x404.png 804w" sizes="(max-width: 1000px) 100vw, 1000px">
<p>From this tab you have access to a number of different tools that can help track down any issues.</p>
<h2>Take it to the Next Level</h2>
<p>Congratulations! You’ve successfully created a bot that can communicate across a <strong>wide range of channels</strong>.</p>
<p>But this demo is just a starting point — the real fun begins when you start adding more and more channels and capabilities to your bot. Building it up to a <strong>Digital Spokesperson</strong>.</p>
<p>You can dig deeper into the Bot Framework in the <a href="https://docs.microsoft.com/en-us/bot-framework/" title="Read more about the Bot Framework developer documentation" target="_blank">Bot Framework Documentation</a> or the <a href="https://docs.microsoft.com/en-us/bot-framework/nodejs/bot-builder-nodejs-overview" title="Learn more about the Bot Builder SDK for Node.js" target="_blank">Bot Builder SDK for Node.js</a>.</p>
<p>Enjoy!</p>
<div>
<div style="border:1px solid #EEE;background:#F5F5F5;padding:20px;">
This post is part of our <em>How to Apply A.I. in Your Business</em> blog series. Be sure to check out our past issues:
<ul>
<li><a href="https://gigaom.com/2017/01/30/building-voice-enabled-products-with-amazon-alexa/" title="Read our Building Voice-Enabled Products With Amazon Alexa post" target="_blank">Building Voice-Enabled Products With Amazon Alexa</a></li>
<li><a href="https://gigaom.com/2017/02/02/cognitive-customer-engagement-using-ibm-watson/" title="Read our Cognitive Customer Engagement Using IBM Watson post" target="_blank">Cognitive Customer Engagement Using IBM Watson</a></li>
<li><a href="https://gigaom.com/2017/02/06/harnessing-visual-data-using-google-cloud/" title="Read our Harnessing Visual Data Using Google Cloud post" target="_blank">Harnessing Visual Data Using Google Cloud</a></li>
<li><a href="https://gigaom.com/2017/02/08/building-a-recommendation-engine-using-microsoft-azure/" title="Read our Building a Recommendation Engine Using Microsoft Azure post" target="_blank">Building a Recommendation Engine Using Microsoft Azure</a></li>
<li><a href="https://gigaom.com/2017/02/27/predicting-marketing-campaign-response-using-amazon-machine-learning/" title="Read our Predicting Marketing Campaign Response Using Amazon Machine Learning post" target="_blank">Predicting Marketing Campaign Response Using Amazon Machine Learning</a></li>
<li><a href="https://gigaom.com/2017/03/13/unleashing-a-i-powered-conversation-with-ibm-watson/" title="Read our Unleashing A.I.-Powered Conversation With IBM Watson post" target="_blank">Unleashing A.I.-Powered Conversation With IBM Watson</a></li>
<li><a href="https://gigaom.com/2017/03/27/get-into-the-mind-of-your-customer-using-googles-sentiment-analysis-tools/" title="Read our Get into the Mind of Your Customer Using Google’s Sentiment Analysis Tools post" target="_blank">Get into the Mind of Your Customer Using Google’s Sentiment Analysis Tools</a></li>
<li><a href="https://gigaom.com/2017/04/10/discover-your-customers-deepest-feelings-using-microsoft-facial-recognition/" title="Read our Discover Your Customers’ Deepest Feelings Using Microsoft Facial Recognition post" target="_blank">Discover Your Customers’ Deepest Feelings Using Microsoft Facial Recognition</a></li>
<li><a href="https://gigaom.com/2017/04/24/give-your-products-the-power-of-speech-using-amazon-polly/" title="Read our Give Your Products the Power of Speech Using Amazon Polly post" target="_blank">Give Your Products the Power of Speech Using Amazon Polly</a></li>
<li><a href="https://gigaom.com/2017/05/08/computers-are-opening-their-eyes-and-theyre-already-better-at-seeing-than-we-are/" title="Read our Computers Are Opening Their Eyes — and They’re Already Better at Seeing Than We Are post" target="_blank">Computers Are Opening Their Eyes — and They’re Already Better at Seeing Than We Are</a></li>
<li><a href="https://gigaom.com/2017/05/22/how-to-predict-when-youre-going-to-lose-a-subscriber/" title="Read our How to Predict When You’re Going to Lose a Subscriber post" target="_blank">How to Predict When You’re Going to Lose a Subscriber</a></li>
</ul>
<p>And be on the lookout for future issues, they come out every other Monday.
</p>
</div>
</div>
							</section>

									<div id="ad-billboard-container" class="ad go-ad ad-970x250">
			<div class="advertisement-notice">Advertisement</div>
			<div class="ad-container" id="ad-billboard"
				data-ad-dfp="/1008864/tech_billboard"
				data-ad-slot="tech_billboard"
				data-ad-width="970"
				data-ad-height="250"
			>
				<!-- DFP AD SLOT: tech_billboard -->
			</div>
		</div>
		
							<footer class="article-footer wrap">
								<p class="tags"><span class="tags-title">Tags</span><br /><span itemprop="keywords"><a href="https://gigaom.com/tag/ai/" rel="tag">ai</a> <a href="https://gigaom.com/tag/gigaomai/" rel="tag">GigaomAI</a></span></p>								<div class="related-stories articles">
	<header class="subheader">Related stories</header>
	<ul>
					<li class="related-post">
				<a class="title" href="https://gigaom.com/2017/06/02/ai-startups-if-you-say-you-are-doing-ai-show-it/" rel="bookmark" title="Permanent Link to AI Startups: If You Say You Are Doing AI, Show It">
					<span class="thumbnail">
						<img width="48" height="48" src="https://gigaom.com/wp-content/uploads/sites/1/2017/06/bigstock-Business-Woman-Prepare-Documen-152882819-48x48.jpg" class="attachment-small-square-thumbnail size-small-square-thumbnail wp-post-image" alt="" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/06/bigstock-Business-Woman-Prepare-Documen-152882819-48x48.jpg 48w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/bigstock-Business-Woman-Prepare-Documen-152882819-85x85.jpg 85w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/bigstock-Business-Woman-Prepare-Documen-152882819-50x50.jpg 50w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/bigstock-Business-Woman-Prepare-Documen-152882819-180x180.jpg 180w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/bigstock-Business-Woman-Prepare-Documen-152882819-300x300.jpg 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/06/bigstock-Business-Woman-Prepare-Documen-152882819-600x600.jpg 600w" sizes="(max-width: 48px) 100vw, 48px" />					</span>
					AI Startups: If You Say You Are Doing AI, Show It				</a>
			</li>
						<li class="related-post">
				<a class="title" href="https://gigaom.com/2017/05/31/marchex/" rel="bookmark" title="Permanent Link to Review:  IBM’s Watson Can Learn a lot from Marchex Speech Analytics">
					<span class="thumbnail">
						<img width="48" height="48" src="https://gigaom.com/wp-content/uploads/sites/1/2006/08/logan_olson_hq-48x48.jpg" class="attachment-small-square-thumbnail size-small-square-thumbnail wp-post-image" alt="" srcset="https://gigaom.com/wp-content/uploads/sites/1/2006/08/logan_olson_hq-48x48.jpg 48w, https://gigaom.com/wp-content/uploads/sites/1/2006/08/logan_olson_hq-100x100.jpg 100w" sizes="(max-width: 48px) 100vw, 48px" />					</span>
					Review:  IBM’s Watson Can Learn a lot from Marchex Speech Analytics				</a>
			</li>
						<li class="related-post">
				<a class="title" href="https://gigaom.com/2017/05/22/how-to-predict-when-youre-going-to-lose-a-subscriber/" rel="bookmark" title="Permanent Link to How to Predict When You&#8217;re Going to Lose a Subscriber">
					<span class="thumbnail">
						<img width="48" height="48" src="https://gigaom.com/wp-content/uploads/sites/1/2017/05/juggler-1216853_1920-48x48.jpg" class="attachment-small-square-thumbnail size-small-square-thumbnail wp-post-image" alt="" srcset="https://gigaom.com/wp-content/uploads/sites/1/2017/05/juggler-1216853_1920-48x48.jpg 48w, https://gigaom.com/wp-content/uploads/sites/1/2017/05/juggler-1216853_1920-85x85.jpg 85w, https://gigaom.com/wp-content/uploads/sites/1/2017/05/juggler-1216853_1920-50x50.jpg 50w, https://gigaom.com/wp-content/uploads/sites/1/2017/05/juggler-1216853_1920-180x180.jpg 180w, https://gigaom.com/wp-content/uploads/sites/1/2017/05/juggler-1216853_1920-300x300.jpg 300w, https://gigaom.com/wp-content/uploads/sites/1/2017/05/juggler-1216853_1920-600x600.jpg 600w" sizes="(max-width: 48px) 100vw, 48px" />					</span>
					How to Predict When You&#8217;re Going to Lose a Subscriber				</a>
			</li>
						<li class="related-post">
				<a class="title" href="https://gigaom.com/2017/05/18/datagravity-brings-behavior-driven-data-management-to-veeam-environments/" rel="bookmark" title="Permanent Link to DataGravity Brings Behavior-Driven Data Management to Veeam Environments">
					<span class="thumbnail">
						<img width="48" height="48" src="https://gigaom.com/wp-content/uploads/sites/1/2009/11/iphone-malware-48x48.jpg" class="attachment-small-square-thumbnail size-small-square-thumbnail wp-post-image" alt="" srcset="https://gigaom.com/wp-content/uploads/sites/1/2009/11/iphone-malware-48x48.jpg 48w, https://gigaom.com/wp-content/uploads/sites/1/2009/11/iphone-malware-100x100.jpg 100w" sizes="(max-width: 48px) 100vw, 48px" />					</span>
					DataGravity Brings Behavior-Driven Data Management to Veeam Environments				</a>
			</li>
				</ul>
</div>
							</footer>

							<div class="wrap">
										<div id="ad-d-container" class="ad go-ad ad-300x250">
			<div class="advertisement-notice">Advertisement</div>
			<div class="ad-container" id="ad-d"
				data-ad-dfp="/1008864/tech_300x250_low"
				data-ad-slot="tech_300x250_low"
				data-ad-width="300"
				data-ad-height="250"
			>
				<!-- DFP AD SLOT: tech_300x250_low -->
			</div>
		</div>
		
<div id="comments" class="active"> 		
		<div id="respond" class="comment-respond">
		<header><h3 id="reply-title" class="comment-reply-title">Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/06/06/the-future-of-business-is-a-digital-spokesperson-lets-build-a-preview-using-microsofts-bot-framework/#respond" style="display:none;">Cancel reply</a></small></h3><a class="community-guidelines" href="https://gigaom.com/community-guidelines/">Community guidelines</a></header>			<form action="https://gigaom.com/wp-comments-post.php?wpe-comment-post=gigaom" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Comment" /> <input type='hidden' name='comment_post_ID' value='953710' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>		<p class="community-guidelines">Be sure to review our <a href="/community-guidelines/" title="Community Guidelines">Community Guidelines</a>. By continuing you are agreeing to our <a href="/terms-of-service/" title="Terms of Service">Terms of Service</a> and <a href="/privacy-policy/" title="Privacy Policy">Privacy Policy</a>.</p>
					</form>
			</div><!-- #respond -->
	</div>
							</div>
						</article>
									</main>

			
	

		</div>

	</div>

			<footer class="footer" role="contentinfo" itemscope itemtype="http://schema.org/WPFooter">
				<nav role="navigation">
					<ul class="nav topics-nav tags-to-topics cf">
						<li><a href="/archives/apple/">Apple</a></li>
						<li><a href="/archives/automotive-transportation/">Automotive &amp; Transportation</a></li>
						<li><a href="/archives/broadband-cable-internet/">Broadband, Cable &amp; Internet</a></li>
						<li><a href="/archives/business-finance/">Business &amp; Finance</a></li>
						<li><a href="/archives/cloud-data/">Cloud &amp; Data</a></li>
						<li><a href="/archives/computing-devices-electronics/">Computing Devices &amp; Electronics</a></li>
						<li><a href="/archives/development-design/">Development &amp; Design</a></li>
						<li><a href="/archives/employment/">Employment</a></li>
						<li><a href="/archives/energy-environment/">Energy &amp; Environment</a></li>
						<li><a href="/archives/gaming/">Gaming</a></li>
						<li><a href="/archives/google/">Google</a></li>
						<li><a href="/archives/government-law/">Government &amp; Law</a></li>
						<li><a href="/archives/internet-of-things/">Internet of Things</a></li>
						<li><a href="/archives/lifestyle/">Lifestyle</a></li>
						<li><a href="/archives/location/">Location</a></li>
						<li><a href="/archives/marketing-advertising-research/">Marketing, Advertising &amp; Research</a></li>
						<li><a href="/archives/media/">Media</a></li>
						<li><a href="/archives/media-sharing-streaming/">Media Sharing &amp; Streaming</a></li>
						<li><a href="/archives/microsoft/">Microsoft</a></li>
						<li><a href="/archives/miscellaneous/">Miscellaneous</a></li>
						<li><a href="/archives/people/">People</a></li>
						<li><a href="/archives/phones/">Phones</a></li>
						<li><a href="/archives/productivity/">Productivity</a></li>
						<li><a href="/archives/publishing/">Publishing</a></li>
						<li><a href="/archives/retail-ecommerce/">Retail &amp; Ecommerce</a></li>
						<li><a href="/archives/security-privacy/">Security &amp; Privacy</a></li>
						<li><a href="/archives/social/">Social</a></li>
						<li><a href="/archives/software-services/">Software &amp; Services</a></li>
						<li><a href="/archives/sports-fitness/">Sports &amp; Fitness</a></li>
						<li><a href="/archives/wireless-telecom/">Wireless &amp; Telecom</a></li>
					</ul>
				</nav>

				<nav role="navigation">
					<div class="topics-links cf"><ul id="menu-main-menu-1" class="nav topics-nav cf"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-949624"><a href="/topics/">Topics</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-949627"><a href="/analysts/">Analysts</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-949626"><a href="/events/">Events</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-949625"><a href="/reports/">Reports</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-953357"><a href="https://gigaom.com/publishers-corner/">Publisher&#8217;s Corner</a></li>
</ul></div>				</nav>

				<div id="inner-footer" class="wrap cf">

							<div class="gigaom-logo" itemscope itemtype="http://schema.org/Organization">
			<a href="https://gigaom.com" rel="publisher" title="Gigaom">
				<img src="https://gigaom.com/wp-content/themes/go-ossein/library/images/gigaom-logo.svg" alt="Gigaom logo">
			</a>
		</div>
		
					<nav role="navigation">
						<div class="footer-links cf"><ul id="menu-footer-menu" class="nav footer-nav cf"><li id="menu-item-601821" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-601821"><a href="/about/">About</a></li>
<li id="menu-item-601825" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-601825"><a href="/contact/">Contact</a></li>
<li id="menu-item-949555" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-949555"><a href="/advertise/">Advertising</a></li>
<li id="menu-item-601819" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-601819"><a href="/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-601820" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-601820"><a href="/terms-of-service/">Terms of Service</a></li>
<li id="menu-item-950801" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-950801"><a href="https://gigaom.com/content/resource-center/">Resource Center</a></li>
</ul></div>					</nav>

					<ul class="share-list">
						<li><a href="https://twitter.com/Gigaom" class="goicon icon-twitter" title="Share on Twitter"></a></li>
						<li><a href="https://www.facebook.com/Gigaom" class="goicon icon-facebook" title="Share on Facebook"></a></li>
						<li><a href="https://www.linkedin.com/company/gigaom" class="goicon icon-linkedin" title="Share on LinkedIn"></a></li>
						<li><a href="/feed/" class="goicon icon-rss" title="Follow using RSS"></a></li>
						<li><a href="/subscription/sign-up/newsletter/" class="goicon icon-email" title="Get our Newsletter"></a></li>
					</ul>

					<p class="source-org copyright">2017 <a href="https://www.knowingly.com/">Knowingly, Inc.</a> All Rights Reserved.</p>

				</div>
			</footer>
		</div>

				<script type='text/javascript'>
		var googletag = googletag || {};
		googletag.cmd = googletag.cmd || [];
		(function() {
			var gads = document.createElement("script");
			gads.async = true;
			gads.type = "text/javascript";
			var useSSL = "https:" == document.location.protocol;
			gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
			var node =document.getElementsByTagName("script")[0];
			node.parentNode.insertBefore(gads, node);
		})();
		</script>
				<!-- Quantcast -->
		<script type="text/javascript">
		var _qevents = _qevents || [];

		(function() {
		var elem = document.createElement('script');
		elem.src = (document.location.protocol == 'https:' ? 'https://secure' : 'http://edge') + '.quantserve.com/quant.js';
		elem.async = true;
		elem.type = 'text/javascript';
		var scpt = document.getElementsByTagName('script')[0];
		scpt.parentNode.insertBefore(elem, scpt);
		})();

		_qevents.push({
		qacct:'p-7f76HAgni1Oqs'
		});
		</script>
		<noscript>
		<div style="display:none;">
		<img src="//pixel.quantserve.com/pixel/p-7f76HAgni1Oqs.gif" height="1" width="1" alt="Quantcast"/>
		</div>
		</noscript>
		<!-- comScore -->
		<script>
			var _comscore = _comscore || [];
			_comscore.push({ c1: "2", c2: "13557238" });
			(function() {
				var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = 'async';
				s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
				el.parentNode.insertBefore(s, el);
			})();
		</script>
		<noscript>
			<img src="http://b.scorecardresearch.com/p?c1=2&amp;c2=13557238&amp;cv=2.0&amp;cj=1" alt="comScore" />
		</noscript>
		<!-- Nielsen -->
		<script type="text/javascript">
		(function () {
			var d = new Image(1, 1);
			d.onerror = d.onload = function () {
				d.onerror = d.onload = null;
			};
			d.src = ["//secure-us.imrworldwide.com/cgi-bin/m?ci=us-thestreet&cg=0&cc=1&si=", escape(window.location.href), "&rp=", escape(document.referrer), "&ts=compact&rnd=", (new Date()).getTime()].join('');
		})();
		</script>
		<noscript>
			<div>
				<img src="//secure-us.imrworldwide.com/cgi-bin/m?ci=us-thestreet&amp;cg=0&amp;cc=1&amp;ts=noscript" width="1" height="1" alt="" />
			</div>
		</noscript>
		<!-- Skimlinks -->
		<script type="text/javascript" src="//s.skimresources.com/js/90965X1544611.skimlinks.js"></script>
		<script type="text/javascript">(function() {function addEventListener(element,event,handler) {
	if(element.addEventListener) {
		element.addEventListener(event,handler, false);
	} else if(element.attachEvent){
		element.attachEvent('on'+event,handler);
	}
}function maybePrefixUrlField() {
	if(this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if( urlFields && urlFields.length > 0 ) {
	for( var j=0; j < urlFields.length; j++ ) {
		addEventListener(urlFields[j],'blur',maybePrefixUrlField);
	}
}/* test if browser supports date fields */
var testInput = document.createElement('input');
testInput.setAttribute('type', 'date');
if( testInput.type !== 'date') {

	/* add placeholder & pattern to all date fields */
	var dateFields = document.querySelectorAll('.mc4wp-form input[type="date"]');
	for(var i=0; i<dateFields.length; i++) {
		if(!dateFields[i].placeholder) {
			dateFields[i].placeholder = 'YYYY-MM-DD';
		}
		if(!dateFields[i].pattern) {
			dateFields[i].pattern = '[0-9]{4}-(0[1-9]|1[012])-(0[1-9]|1[0-9]|2[0-9]|3[01])';
		}
	}
}

})();</script><script type='text/javascript' src='https://gigaom.com/wp-content/plugins/go-ui/components/js/jquery.inline-bumpdown.js?ver=1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var go_advisories_sign_up_settings = {"ajax_url":"https:\/\/gigaom.com\/wp-admin\/admin-ajax.php","warn_email_domains":["gmail.com","yahoo.com","hotmail.com","outlook.com","aol.com","qq.com","comcast.net","mac.com","me.com"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://gigaom.com/wp-content/plugins/go-advisories/components/js/go-advisories-sign-up.js?ver=1445622806'></script>
<script type='text/javascript' src='https://gigaom.com/wp-content/plugins/go-ui/components/js/external/colorbox/jquery.colorbox-min.js?ver=1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var go_local_subscriptions_settings = {"user_has_email":"0","ajax_url":"https:\/\/gigaom.com\/wp-admin\/admin-ajax.php","update_converted_meta_url":"https:\/\/gigaom.com\/wp-admin\/admin-ajax.php?action=go-local-subscriptions-update-converted-meta&_wpnonce=4ef43f69e9","confirmation_url":"https:\/\/gigaom.com\/wp-content\/plugins\/go-local-subscriptions\/components\/templates\/confirmation.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://gigaom.com/wp-content/plugins/go-local-subscriptions/components/js/go-local-subscriptions-sign-up.js?ver=1445622806'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pwsL10n = {"unknown":"Password strength unknown","short":"Very weak","bad":"Weak","good":"Medium","strong":"Strong","mismatch":"Mismatch"};
/* ]]> */
</script>
<script type='text/javascript' src='https://gigaom.com/wp-admin/js/password-strength-meter.min.js?ver=4.7.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var go_ads = {"dfp_targeting":{"vertical":["ai"],"post_tag":["ai","gigaomai"]},"debug":"","defined_slots":[],"defined_objects":[]};
/* ]]> */
</script>
<script type='text/javascript' src='https://gigaom.com/wp-content/plugins/go-ads/components/js/go-ads.js?ver=1445622806'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wc_add_to_cart_params = {"ajax_url":"https:\/\/gigaom.com\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/2017\/06\/06\/the-future-of-business-is-a-digital-spokesperson-lets-build-a-preview-using-microsofts-bot-framework\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View Cart","cart_url":"https:\/\/gigaom.com\/cart\/","is_cart":"","cart_redirect_after_add":"no"};
/* ]]> */
</script>
<script type='text/javascript' src='//gigaom.com/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js?ver=2.6.13'></script>
<script type='text/javascript' src='//gigaom.com/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.70'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var woocommerce_params = {"ajax_url":"https:\/\/gigaom.com\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/2017\/06\/06\/the-future-of-business-is-a-digital-spokesperson-lets-build-a-preview-using-microsofts-bot-framework\/?wc-ajax=%%endpoint%%"};
/* ]]> */
</script>
<script type='text/javascript' src='//gigaom.com/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js?ver=2.6.13'></script>
<script type='text/javascript' src='https://gigaom.com/wp-content/plugins/go-ui/components/js/external/jquery.cookie.js?ver=1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wc_cart_fragments_params = {"ajax_url":"https:\/\/gigaom.com\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/2017\/06\/06\/the-future-of-business-is-a-digital-spokesperson-lets-build-a-preview-using-microsofts-bot-framework\/?wc-ajax=%%endpoint%%","fragment_name":"wc_fragments"};
/* ]]> */
</script>
<script type='text/javascript' src='//gigaom.com/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=2.6.13'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/gigaom.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://gigaom.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.2'></script>
<script type='text/javascript' src='https://gigaom.com/wp-includes/js/comment-reply.min.js?ver=4.7.5'></script>
<script type='text/javascript' src='https://gigaom.com/wp-content/themes/go-ossein/library/js/go-ossein.js?ver=7'></script>
<script type='text/javascript' src='https://gigaom.com/wp-content/plugins/go-ui/components/js/external/handlebars.js?ver=1'></script>
<script type='text/javascript' src='https://gigaom.com/wp-content/themes/go-ossein/library/js/go-ossein-gcse.js?ver=7'></script>
<script type='text/javascript' src='https://gigaom.com/wp-includes/js/wp-embed.min.js?ver=4.7.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mc4wp_forms_config = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://gigaom.com/wp-content/plugins/mailchimp-for-wp/assets/js/forms-api.min.js?ver=4.0.12'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mc4wp_ajax_vars = {"loading_character":"\u2022","ajax_url":"https:\/\/gigaom.com\/wp-admin\/admin-ajax.php?action=mc4wp-form","error_text":"Oops. Something went wrong. Please try again later."};
/* ]]> */
</script>
<script type='text/javascript' src='https://gigaom.com/wp-content/plugins/mc4wp-premium/ajax-forms/assets/js/ajax-forms.min.js?ver=3.2.2'></script>
<!--[if lte IE 9]>
<script type='text/javascript' src='https://gigaom.com/wp-content/plugins/mailchimp-for-wp/assets/js/third-party/placeholders.min.js?ver=4.0.12'></script>
<![endif]-->
	</body>
</html>