Getting Quicksilver to Jive With Snow Leopard

Quicksilver logo

From what I’ve been reading on support forums, some users of Quicksilver saw no affect from upgrading their machines to Snow Leopard. I however, was not one of those people. And although I am warming more and more to Google Quick Search Box, I still supplement my usage of QSB with Quicksilver where the former is lacking in features. So I tinkered around until I was able to resuscitate and use Quicksilver again under Snow Leopard.

Been having similar problems? Let me walk you through the process.

First, make sure you’ve upgraded to the most current version of Quicksilver. B56a7 is the most up to date version, that is built for Snow Leopard. Download it here if you haven’t already done so. Once that’s done, go ahead and try running Quicksilver. If you’re lucky, that’s all that is needed. If you’re not, don’t fret, because we’ll figure it out in short order.

What I found to be the issue with getting my installation of Quicksilver working, was the huge collection of plug-ins that I’ve installed over the years. Plug-ins (in my opinion) are what have made Quicksilver what it is to so many of us today. They extend it into nearly every nook and cranny of your Mac, allowing you to control everything. The downside, is that some of those plug-ins are broken in OS 10.6’s new underlying architecture.

So let’s fix that.

  • Navigate (using Finder) to ~/Library/Application Support/Quicksilver
  • Open the ‘PlugIns’ folder
  • Select all of the plug-in files, and drag them someplace else (I suggest the Desktop, for easy access, as we’ll be using them again)

Now, let’s make sure Quicksilver opens before we go any further. If at this point the answer is no, I’d recommend posting the question to the Blacktree Quicksilver group on Google. (I’m happy to help too of course, but I’m not that bright, and if I can’t duplicate your setup, there’s a slim chance I’ll be useful on the subject.) If on the other hand, Quicksilver is starting up, let’s continue.

  • Quit Quicksilver
  • Drag the first plug-in (that you moved somewhere, like your Desktop) back into that ~/Library/Application Support/Quicksilver/PlugIns folder
  • Launch Quicksilver

Did Quicksilver remain open? Or did is crash after a few moments? If Quicksilver is still running, then that plug-in was not the culprit, and you may return to the ‘Quit Quicksilver’ step, and repeat with the next plug-in file. If Quicksilver bombed after launch, continue on below. (Does this feel like a choose your own adventure to anyone else?)

  • In the ~/Library/Application Support/Quicksilver/PlugIns folder, delete the plug-in that you just placed there

Unfortunately, that plug-in was no longer valid under the new Snow Leopard architecture. At this point, you should rinse and repeat (so to speak), moving the next plug-in file from your Desktop, into the Quicksilver PlugIns folder, and then seeing if Quicksilver crashes or not. Do this until you’ve deleted the bad plug-ins, and have the rest installed, with Quicksilver running happily again.

As a point of reference, the plug-ins that appear to cause me trouble were:
– Airport Module
– Services Menu
– Text Manipulations (not 100 percent certain about this one)
– Image Manipulations (not 100 percent certain about this one)
– Any interface modules seem to be causing issues as well

The downside is, you may lose some level of functionality (if you were even using that particular plug-in) from Quicksilver. The upside is that you’ll still be able to run Quicksilver, if somewhat pared-down in capability. In my case, I didn’t lose anything I’d been using regularly. In the event that you have actually lost something of use to you, you can either downgrade back to OS 10.5.8 (probably not realistic), or wait on Google QSB to get up to speed, as I have seen some great strides on that application in a short period of time.

loading

Comments have been disabled for this post